Ускорил свой рабочий линукс

Оказалось, что при всей любви к линуксам я не любитель unity. С самого его появления в ubuntu он мне не нравился. Я сначала пытался сбежать на mint, но появилось ощущение ухода в левую ветвь дистрибутивов. Как-то внезапно у меня убунты поставились на все компы. Сейчас я понял, что меня раздражает не только сама unity, но и тормоза с ней связанные. Оказалось всё очень просто:

apt-get purge `dpkg -l | awk '{print $2}' | grep -E 'gnome|unity'`
apt-get install xubuntu-desktop
apt-get autoremove

Какие-то приложения (в моём случае firefox и dropbox понадобилось переустановить, но они встали и подхватили существующие настройки. Зато всё быстро летает теперь. И нет необходимости в переустановке системы.

Adobe Flash Player всё?

Читаю на сайте adobe.com:


ПРИМЕЧАНИЕ. Adobe Flash Player 11.2 будет последней версией, поддерживающей Linux в качестве платформы. Adobe будет продолжать обеспечивать ретроподдержку безопасности Flash Player 11.2 для Linux.

Это то, что я думаю? Это адоб умирает или линукс?

Внезапная ошибка OpenX

Перенос сайта с OpenX с одного сервера на другой. Фактически, обновление версии софта. Вылезает ошибка:

MESSAGE: Use of undefined constant phpAds_dbmsname - assumed 'phpAds_dbmsname'
TYPE: Notice
FILE: /var/www/clients/client1/web1/web/ads/lib/max/language/en/settings.lang.php
LINE: 62
DEBUG INFO:

57 $GLOBALS['strTablePrefixInvalid'] = "Table prefix contains invalid characters";
58 $GLOBALS['strTableInUse'] = "The database which you specified is already used for ".MAX_PRODUCT_NAME.", please use a different table prefix, or read the UPGRADE.txt file for upgrading instructions.";
59 $GLOBALS['strNoVersionInfo'] = "Unable to select the database version";
60 $GLOBALS['strInvalidVersionInfo'] = "Unable to determine the database version";
61 $GLOBALS['strInvalidMySqlVersion'] = "" . MAX_PRODUCT_NAME." requires MySQL 4.0 or higher to function correctly. Please select a different database server.";

... и т.д.При этом само приложение выдаёт строку, которую я нахожу на картинке:

И что бы вы думали? Нашел на одном форуме ответ. Оказалось, что openx не понимает спецсимволы в пароле MySQL. Надо снова возвращаться к понятным именам и паролям. Теперь снова стоит пользователь user и пароль password. Всё работает, чего и вам всем советую.

Список путей непустых файлов в архиве rar

Если уже я написал код для получения списка непустых файлов в архиве rar, то почему бы не оставить его здесь?

rar v /data3/rars/month-20141003232102.rar | sed '/%/!N;s/\n/ /' | awk '$2>0 {print $1}'

Основная идея в том, что rar vb blablabla.rar даёт красивый список, но в нём присутствуют и пустые файлы, что вводило меня в заблуждение. Сейчас не входят.

Сообщите злоумышленникам свой пароль от почты!

Очень хорошо, когда пользователи умеют читать по-английски, а так же послушно выполняют все рекомендации сисадминов. А может быть и нет, судите сами.

На днях послушный пользователь сообщил, что не смог выполнить увеличение размера своего почтового ящика по инструкции. Даже похвастался, что web-интерфейсом пользуется редко, но пароль помнит. И прислал письмо с «инструкцией»:
mailvirus

Ссылка в письме ведёт на страничку с логином:
mailvirus2

Пользователь попробовал залогиниться, но ничего не произошло. Страница ничего не делает, кроме как записывает ваши адрес и пароль в свою базу данных. Что будут делать с вашим почтовым ящиком злоумышленник — известно только ему. Хорошо, если только спам рассылать от вашего имени.

Что делать, если это произошло? Срочно менять параль от своего почтового ящика.

Что делать, чтобы этого не произошло? Неплохо быть внимательным, и смотреть на адреса отправителей, на дизайн страниц, на адреса открываемых сайтов, но я не советую вникать в это не специалистам. Я советую сделать закладки для ваших сайтов, и входить в них через закладки или набирая адрес сайта вручную. Как правило современные браузеры подсказывают по нескольким буквам посещённые вами ранее адреса. И тогда, получив письмо о том, что кто-то прокомментировал ваше сообщение в одноклассниках, вы не станете идти по ссылке из письма, и вводить свои имя и пароль на сайте, который только похож на сайт одноклассников, а войдёте на сайт одноклассников и увидите, что никакого комментария нет.

Посоветуйте онлайн сервис.

Есть желание вести записи и список дел по намечающемуся достаточно объёмному проекту в электронном виде. Например, выписал список дел: подстричь овцу, починить мотоцикл и вылечить печень. Позвонил мастеру по мотоциклу, после звонка породился подчинённый список дел, что купить, куда пригнать мотоцикл для ремонта. Потом позвонил по запчастям. Появился список вариантов где их можно купить. И так далее — по мере уточнения задачи появляются новые дела (или варианты решения), а по мере отбрасывания вариантов или решения вопросов, приближаемся к решению квеста. Может быть, чтобы можно было ещё формировать списки на покупку, списки дел или покупок по географическим точкам. Неплохо бы учитывать стоимость и время для выполненных и планируемых этапов. Может ещё до чего тайм-менеджмент додумался, что будет удобно, но я ещё не выдумал 🙂

Хочется в онлайн (могу сам развернуть, если есть софт), ибо доступ нужен двум-трём человекам, желательно чтобы можно было выбирать кто что делает. Первая мысль была — установить баг-трекер, каждую задачу объявлять багом, но это как-то обидно для проекта, хотя по сути очень близко к требующемуся.

Установка русского времени-даты для сервера Lotus Domino под Debian

(скопировано правильно отсюда)

Lotus Domino + Debian Linux + Date ru_RU ( Отображение даты в «русском» формате на сервере с «локалью» en_US )

6 сентября 2011 в 18:31

OS: Debian GNU/Linux Lenny/Squeeze.
Application: IBM Lotus Domino 8.5 for Linux (xSeries).

Условия: сервер Lotus Domino 8.5 запущен с использованием англоязычной «локали» «en_US.UTF-8», менять которую на иную нежелательно.
Задача: привести формат времени и даты, используемый сервером Lotus Domino, к формату, применяемому в русскоязычных интерфейсах (формат даты и времени «локали» «en_US» «MM/DD/YYYY HH:mm:SS», а нам требуется получить на выходе «DD/MM/YYYY HH:mm:SS»).
nc_01n
Читать далее

Remmina выдаёт невозможность подключиться по RDP к Windows 7

Сегодня утром внезапно remmina под ubuntu перестала подключаться к моей любимой виртуальной машине под Windows 7. Причём, только к одной, к другим серверам и рабочим станциям подключалась так же без проблем, как и раньше. В логе windows при каждой попытке появлялось сообщение:

«The Desktop Window Manager was unable to start because a composited theme is not in use»

Я не думаю, что надо пытаться понять что обозначает это сообщение на самом деле, просто надо в настройках Remmina поменять настройку «Дополнительные -> Безопасность -> RDP». И оно снова начнёт подключаться. Пишу это для того, чтобы в этом вашем гугле была статья, в которой упоминалась бы remmina и текст сообщения об ошибке. 🙂

Зачем, зачем мне утопический единорог?!

Вот скажите мне, зачем надо было обновлять ubuntu до версии 14.10, если 14.04 является LTS? Короче, она всё скачала, но ничего не смогла сконфигурировать, и сказала, что обновиться она не может, а шансов на перезагрузку старой системы чуть меньше, чем нисколько.

Буду ставить 14.10 с нуля. Ну и вот скажие, я действительно учусь на своих ошибках?

1398321687

Установка IBM Notes 9.0.1 (Lotus client) под Ubuntu 14.04

Переустановил десктопный комп с CentOS 6.5 на Ubuntu 14.04. Получил некоторое затруднение в установке клиента IBM Notes. Для тех, кто не в курсе, сообщаю, что Lotus Notes стал называться IBM Notes. Бренд Lotus больше не используется нигде. Сервера — IBM Domino, клиенты IBM Notes. Любители работать «под лотусом» на самом деле работают уже не с лотусом. 🙂

Так вот, при попытке установить клиента Lotus я получил сообщение о том, что всё плохо, и есть неустранимые препятствия в зависимостях. После того, как я порыпался в разные стороны, нашлась инструкция от опытного человека. Основная мысль заключается в том, что он рекомендует разобрать deb-пакет, немного переиначить его заголовок, где описано какие зависимости должны быть, а потом снова собрать пакет, установить те пакеты, которые на самом деле нужны, и установить модифицированный пакет. Для не знающих английский надо просто повторить все приведенные там команды.
ibmnotes
Потом ещё оказалось, что на сайте самого лотуса есть инструкция о том, что достаточно поменять только одну зависимость (точно такой же перепаковкой deb-файла). Правда, эту версию я проверить не смог, потому что установил по первой инструкции.

Fix Pack 2 установился после установки лотуса по первой инструкции без проблем.