Ошибка установки Lotus Notes клиента под Ubuntu

Обновил систему на декстопе. Самая свежая версия системы, самая свежая версия Lotus Notes.

$ sudo dpkg -i ibm-notes-9.0.1.i586.deb
dpkg: из-за ibm-notes-9.0.1.i586.deb, содержащегося в ibm-notes, возникла проблема предварительных зависимостей:
ibm-notes требует предварительной установки gdb

dpkg: error processing archive ibm-notes-9.0.1.i586.deb (--install):
проблема предварительных зависимостей — пакет ibm-notes не будет установлен
При обработке следующих пакетов произошли ошибки:
ibm-notes-9.0.1.i586.deb
$ sudo apt-get install gdb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлена самая новая версия gdb.
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 7 пакетов не обновлено.

Что я делаю не так?

Админы, проверьте у кого сбербанк принимает почту по smtp!

Изучение логов почтового сервера показало, что сбербанк России не хочет принимать от меня почту совсем:

# telnet shark11.sberbank.ru
Trying 194.186.207.33...
telnet: Unable to connect to remote host: Connection refused

sberbank

Я писал им через форму обратной связи, но реакция нулевая. Мой почтовый серер в блеклистах не значится. Проверил с другого сервера, который по-хорошему не должен был ничего туда отправлять, следовательно не мог скомпрометировть себя персонально, тоже сразу отлуп. Проверьте, а у вас открывается телнетовская сессия на их почтовый сервер? Есть подозрение, что они заблокировали какой-то достаточно большой белорусский пул адресов.

Скайп 4.2 под линукс перестал пускать. Новый 4.3 чуть красивее, но по сути тоже самое.

Сегодня меня не впустил в сеть мой любимый скайп под линукс. Наверное, это MS-way, чтобы не поддерживать предыдущую версию продукта. Обновился через репозиторий до 4.3 и всё стало как надо.

Ошибка roundcube: 500 internal server error после обновления

У меня на сервере ISP и Roundcube. Внезапно ошибка 500.

В логе нашлось:

[Mon Jul 07 16:29:32 2014] [error] [client 178.124.111.67] SoftException in Application.cpp:221: File «/usr/share/roundcube/index.php» is not in document root of Vhost «/var/www/ibagroupit.com/web»
[Mon Jul 07 16:29:32 2014] [error] [client 178.124.111.67] Premature end of script headers: index.php

Оказалось, что suphp буянит на тему закрученных требований безопасности. В его конфиге /etc/suphp/suphp.conf лечу это:

Добавляю ещё два пути в docroot (там, где находится roundcube)
docroot=/var/www:${HOME}/public_html:/usr/share:/var/lib

Отключаю проверку:
check_vhost_docroot=false

Отключаю проверку UID
min_uid=0
min_gid=0

Изменений несколько, ибо если сделать одно, то появляется другая ошибка, которая тоже ведёт в этот файл. После этого рестарт apache2 и всё работает как в до обновления.

Использование zabbix в мирных целях

Сегодня сработала поставленная несколько дней назад ловушка. Хотел записаться на тест-драйв мотоцикла минского мото-велозавода, но мест не было. А потом оказалось, что запись на следующий тест-драйв на сайте не открыт. Я сделал на сервере zabbix проверку web-сайта, добавил триггер и мне сообщили на почту про тест-драйв через минуту после появления на сайте новой записи.
zabbix
Так что я уже записался 🙂

SEO в действии

Я уже упоминал о мотоциклетном портале debian-multimedia.org, который создали на освободившемся раскрученном имени известного репозитория. Вчера при поиске клона ёбра в Беларуси столкнулся с другим замечательным SEO решением: minsk-moto.by показывает китайский клон от ММВЗ, а moto-minsk.by ведёт на китайский-китайский клон ёбра по имени Hors (новая версия сайта лучше, на неё идёт переход через меню).

Установка русского языка на телефон HTC One X 4.2.2 из-под Linux

Раньше я был уверен, что знаю, что в телефоне можно зайти в настройки языка и клавиатуры и выбрать русский язык. Теперь я уже в этом не уверен. После обновления телефона до версии android 4.2.2 у меня начались глюки. Оказалось потом, что это не глюки, а улучшения. Но я узнал об этом позже, когда уже сделал сброс настроек на заводские, и уже остался без русского языка в телефоне. Клавиатура русская есть, а меню, проверки орфографии (быстрый набор), поиск телефона по имени — всё пропало.
Читать далее

Запуск OpenMeetings на 80-м порту

Установил я OpenMeetings на сервере debian. Пока ещё не всё, но сервер поднялся. Беда только в том, что логиниться на него надо по http по порту 5080. А на 80-м порту ничего нет. Не удобно это. Поизучав инструкцию на сайте я резво забрался в указанные там файлы конфигурации и установил порты 80 и 443. После перезапуска сервисы не поднялись. Изучение инструкций и почтовой рассылки привело к пониманию того, что на портах выше 1024 сервис слушать ничего не имеет права, только если его из-под рута запустить. Как они в своей инструкции так просто пишут про изменение порта в конфигах — не понимаю. В результате я сделал перенаправление порта средствами iptables по инструкции. Получился такой скрипт:
Читать далее

Установка драйверов Mustek 1200 UB Plus на линукс и XP

Стоял у дочки Mustek 1200 UB, который по техническим причинам надо было заменить на Mustek 1200 UB Plus. Оказалось, что это не просто разные сканеры, а вообще разные сканеры. На компьютере установлено две операционки: Linux Mint и Windows XP. Ставим драйвера:

Читать далее

winmail.dat и postfix

Мой коллега спросил как так могло случиться, что его корреспонденты начали вместо осмысленных аттачей присылать winmail.dat. Я пошуршал на тему такого файла, и оказалось, что winmail.dat это хитропридумнный микрософтом формат кодирования аттачей (TNEF), который никто, кроме аутлука, нативно не умеет, но многие почтовые системы его декодируют на всякий случай, ибо неисповедимы пути пользователей микрософтовскими поделками. Кстати, мой любимый Lotus Domino умеет декодировать этот формат,то есть получатель видит обычный аттач. А postfix и обычный клиент (web-интерфейс, виндовый почтовый клиент (не аутлук), айфончик) видят присоединённый файл winmail.dat. Существует способ прикрутить декодировку этого формата к своему серверу на postfix.

Возникает закономерный вопрос: а надо ли, если это на самом деле извращение, и пользователям аутлука скоро сообщат, чтобы они у себя в настройках указали не использовать эту извращённую кодировку?